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Alibre Design Tutorial:  Loft, Extrude, & Revolve Cut
Loft-Tube-1

Part Tutorial

Exercise 5: Loft-Tube-1 [Complete]

In this Exercise, We will set System Parameters first, then part options.
Then, in sketch mode, we will set the first three sketches of the tube for the loft, and loft them.
Then we will use the Extrude Feature to create the Neck, or - threaded top, as a blank.
Then we will use revolve cut to show simplified threads and hollow out the top neck.
Setting the Color Properties and Saving will follow this.

Launch Alibre Design.
From the Home window - select File, Work Offline. (You may switch to work online later.)
 (Also - Even though these pictures show 'Alibre Design Expert' - these are basic instructions that can
be done without Professional or Expert Versions.)

Open a New Part workspace. From the Home window - click on the New Part icon.
Maximise the Part Workspace Window.

If at any time you are not sure of a keyboard item, see: Keyboard Basics
Set Design Properties.

http://www.aarp.org/computers-howto/Articles/a2002-07-15-keyboardbasics.html
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Select File, Properties.

A)   Select the Tab Marked "General"
• In Description: insert the information: 'Loft-Tube-1'.
• In Curve Smoothness, Select the Radio Button marked 'Automatic'.

B) Select the Tab Marked "Units"
• Check (check mark in box is showing) the Box Show Units for Dimensions.
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• On Display Units - confirm Unit: Millimeters, and Precision: 4.
If Not, Click option button, Select '4', Click to accept.

• On Angle - Confirm Angle: Degrees and Precision: 3. Adjust if not.
• On Spinner Increment - for Length: enter 0.1mm and for Angle: enter 1 degrees.

 Adjust to these parameters if not. Press 'Tab' to move after editing them.

C)   Select the Tab Marked "Physical"
• Change Accuracy: to High. Click on the Calculate Button. Notice the results.
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D)   Select the Tab Marked "Apply Options"
• On Apply Changes to - Click the Radio Button beside The Current Document.
• Click Apply, then Click Close.

Set Part Options.
From Top Text Menu - Select - Tools > Options > (Crtl-Shift-O)

General Tab > Selected or checked off (check off = check mark in box) are:
Global - Show popup on errors,
Hints - All
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Design
- Prompt for newer versions, - Snap to working plane, - Prompt to edit sketch,
- Prompt on detecting parameters with missing external link, - Reorient on extrude,
- Keep model in View, - Prompt when not sketching on face.
Show as Default - Planes, Annotations, and Sketches.
Number of stored previous/next views: 64

Grid Tab> Spacing: Make X: 0.05 mm and Y: 0.05 mm, check off Display grid, and Snap to grid.
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Color Scheme Tab> For Scheme: - confirm - Dark Background Scheme. Click 'OK'.
(You may come back to this at any time later - and edit - or change - any element.)

Proceed to Starting the Sketches, Next Page.
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Start the First Loft Sketch.
From the Sketch Icons > Click Activate Sketch. (The XY-Plane should be selected.)

From the Sketch Icons > Click Rectangle by Two Corners
• Balanced above and below the Horizontal axis (X-Axis), draw a rectangle, approximately

centered on the Vertical axis (Y-Axis) 10 mm wide by 0.2 mm tall.
Locate Cursor by the Readout on the Status Bar.

From the Sketch Icons > Click Dimension  (Add the dimensions to the rectangle)
• Select the right side edge line, (Click, and drag away to place the 0.2 mm dimension.)
• Click to display the Edit Dimension window, press Enter to accept the 0.2 mm Dimension.



Page 8 of 28

• Select the bottom rectangle line, Click, and drag away to place the 10 mm dimension.
• Click to display the Edit Dimension window, press Enter to accept the 10 mm Dimension.

If the Dimension is not these numbers, simply enter these values in the Edit Dimension Box before
pressing Enter.

From the Sketch Icons > Click Options (Under the Constraint Icons)
Select the Symmetric Constraint by Clicking it.
(Pass the mouse slowly over the constraints and a name tip will appear, Symmetric Constraint is 5th

icon from the end of the flyout menu)

• Use the Symmetric constraint to make the top and bottom lines Symmetric about the X-Axis, and
the left and right lines Symmetric about the Y-Axis.

• Click the X-Axis, then the top line, and then the bottom line.

• Click the Y-Axis, then the left edge line, and then the right edge line.
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From the top Icons, click on Select (Beside Undo and Redo Icons) to exit sketch mode.
This creates a new Sketch<1> Displayed in the Design Explorer.

Start the Second Loft Sketch.

First - Position the Viewing area to see the plane, Insert a new plane to place the next sketch on.
• Using a combination of left and right mouse buttons depressed together, rotate the viewing area.
• Left Click the XY-Plane in the workspace or in the Design Explorer.

• Then, Select from the Main Menu - Insert Click > Plane. Click.

• In the Insert Plane popup, confirm the XY-Plane is displayed in the Select Geometry window, or
else re-click on it now.

• For the Plane Offset Distance, Set Distance to 35 mm (Highlight '0', enter 35, Press Tab)
• Click OK. Plane<1> is created, and displayed in the Design Explorer as well as the Workspace.
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Next - Create the Sketch for the upper part of the Lofted Tube. (Select Plane<1>)
• Click the new Plane (Plane<1>) and from the Sketch Icons, Click Select.

• After the Sketch Workspace opens, from the Sketch Icons, click on Circle.
• Click on the Origin, and create a 10 mm Diameter Circle. Click.
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From the Sketch Icons > Click Dimension  (Add the dimensions to the Circle)
• Click on the Origin, and Shift-Click on the Circle

• Drag away to set the Dimension Place, Click to open the Dimension Edit Box.
• Press Enter to accept the dimension (5 mm).

• R5 mm is displayed with an arrow pointing to the circle.
From the top Icons, click on Select (Beside Undo and Redo Icons) to exit sketch mode.
Sketch<2> is now Displayed under Features in Design Explorer.

Start the Third Loft Sketch.

First - Insert a new plane to place the next sketch on.
• Left Click Plane<1> in the workspace or in the Design Explorer. (Rotate View To See It)
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• Then, Select from the Main Menu - Insert Click > Plane. Click.

• In the Insert Plane popup, confirm Plane<1> is displayed in the Select Geometry window;
or else re-click on it now.

• For the Plane Offset Distance, Set Distance to 3 mm (press Tab)
• The new plane is displayed - showing in light blue where it will be if created.

• Click OK. Plane<2> is created. Click off in the open area in the part workspace to de-select it.

Next - Create the Sketch for the upper part of the Lofted Tube. (Select Plane<2>)
• Click the new Plane (Plane<2>) and from the Sketch Icons, Click Select.
• After the Sketch Workspace opens, from the Sketch Icons, click on Circle.
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• Click on the Origin, and drag the cursor out along the Y-Axis to create a 5.2 mm Diameter Circle.
• Click to set it.

From the Sketch Icons > Click Dimension  (Add the dimensions to the Circle)
• Click on the Origin, and Shift-Click on the circle,

• Drag away and click to set the Dimension Place,
• Press Enter to accept the dimension (2.6 mm),
• R2.6 mm is displayed with an arrow pointing to the circle.

From the Sketch Icons, click on Activate Sketch (Top Icon) to exit sketch mode.
Sketch<3> is created.
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Create the Loft
From the main menu, Click Feature > select Boss > Loft.
(Or Click Loft Boss from the Feature Icons)

• From the Loft Boss popup, click in the White area under Cross Sections to prepare it for picking
• In the Design Explorer, click on Sketch<1>, then Shift-Click on Sketch<2>, and Sketch<3>

• You will see the three sketch's you have selected appear under Sketch/Face
• A  selection box for each will appear under Maintain Tangent
• Under Take-Off Factor it will now show 0.00.
• On the right, Minimize twist is currently selected. Leave it that way.
• In the selection area beside Label: it is defaulting to Loft<3>. This is fine for now.
• Click OK. Your new lofted tube will be displayed (highlighted in yellow, initially)
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• Using a combination of left and right mouse buttons depressed together, rotate the viewing area.
You can see the result looks nothing like a Toothpaste or Make-up Squeeze Tube as it is!

So - we will now edit the Tangent and Take-Off factors in the loft boss selection popup.
First, we will just select the Tangent, and look at what the default value of 1.00 gives us.
To see what is happening, we will select Tangent one at a time, for sketches 1 - 3.

Edit the Loft: Right-Click on Loft<3> in the Design Explorer
• Click on Edit in the drop down menu

• From the Loft Boss popup, click in the first selection box under Maintain Tangent beside
Sketch<1>

• Click OK. You can see the base sketch<1> (the skinny rectangle) is now predominant.
• Its control extends quite far up the feature.

Let's now switch this to Sketch<2> and see the effects there.
Edit the Loft: Right-Click on Loft<3> in the Design Explorer
• Click on Edit in the drop down menu
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• From the Loft Boss popup, click in the first selection box under Maintain Tangent beside
Sketch<1> to de-select it.

• Now click on the selection box beside Sketch<2>
• Click OK.  You can see the sketch<2> (the circle) is now predominant.
• Its control extends quite far down the feature.

Let's now switch this to Sketch<3> and see.
Edit the Loft: Right-Click on Loft<3> in the Design Explorer
• Click on Edit in the drop down menu

• From the Loft Boss popup, click in the first selection box under Maintain Tangent beside
Sketch<2> to de-select it.

• Now click on the selection box beside Sketch<3>
• Click OK. You can see the sketch<3> (the small circle) is now predominant.
• Its control also forces a new shape quite far down the feature.

So - you can see that simply selecting Tangent, causes quite a bit of change in the features you
are creating, depending on where you force the tangent priority.
Now let's make them all Tangent.
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Edit the Loft: Right-Click on Loft<3> in the Design Explorer
• Click on Edit in the drop down menu

• From the Loft Boss popup, click in the first selection box under Maintain Tangent beside
Sketch<1>,

• Now click on the selection box beside Sketch<2>. (Sketch<3> should still be selected)
• Click OK.

Well! This doesn't get us all the way there either!
So - we will adjust the Take-Off Values to get the results we want.

Edit the Loft: Right-Click on Loft<3> in the Design Explorer
• Click on Edit in the drop down menu.

• In the Loft Boss popup, double-click in the Take-Off Factor beside Sketch<1>
• Click & Drag the mouse over the figure (1.00) to Highlight it,
• Enter 0.1. Press Tab.

• Now, double-click in the Take-Off Factor beside Sketch<2>,
• Click & Drag the mouse over the figure (1.00) to Highlight it,
• Enter 0.7 Press Tab.
• Finally, Now, double-click in the Take-Off Factor beside Sketch<3>,
• Click & Drag the mouse over the figure (1.00) to Highlight it,
• Enter 0.4 Press Tab.



Page 18 of 28

• Click OK. Now we have a reasonable approximation of your typical squeeze tube!

But Wait - there is more to add! The threaded top (Spout) of the tube!

To make the Spout, or threaded top, diameter match the size of the small circle at the upper
end of the loft, we will use Project to Sketch from the loft itself.
• Using a combination of left and right mouse buttons depressed together, rotate the viewing area.
• Click on the Circular end of the Lofted Tube

• Select Project to Sketch from the Main Sketch Menu, or Project to Sketch in the Sketch Icons.

• In the Project to Sketch popup, in the Entities to project selection area, Face<1> now shows.
• Face<1> should now show under Entities to project.
• Under Options, the Radio Button for Create sketch Figure is selected. Leave it like this.
• For now - we will leave Maintain association to source entity unchecked.
• Click OK. This has created Sketch<4>, a circle with two short lines dividing it in half.

(They are from the sketch<1> edges.)
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Now we will extrude this to make the spout.

While still in the sketch mode, click on Extrude Boss from the Feature Icons.
• In the Extrude Boss popup menu, Sketch<4> should be selected under Sketch,
• Leave Type: set at To Depth, and Direction Checked for Along Normal.
• Set Depth at 3 mm. (Highlight the value, and enter 3, press Tab.)

• Leave Draft Angle at 0,
• Label: is Extrusion<4> - may be left as is, or named to suit you.
• The preview shows the location of the spout extension.
• Click OK. This has now created the feature we will customize next.
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Create the Hollow Spout and Simple Threads.
Click on the YZ-Plane in Design Explorer, then Click on Activate Sketch, from the top of the
Sketch Icons.

• In the Sketch Workspace, First click on the Rectangle by Two corners Icon,
• Then click on the axis (Green Line), outside of the existing extruded spout,
• drag over and up until you are near the edge of the extruded circle, and on the line for Plane<2>,
• Click.

Confirm the Rectangle is on the lines representing the Z-axis and Plane<3>
• Click on the Zoom to Window Icon in the top row of Icons, and view close-up at the Rectangle

and the Z-Axis. (Click above and left of the lower left corner of the rectangle, and drag down and
to the right of this corner, creating a small selection rectangle, Release)

• If all is well, Click on Previous View  (A bold Left Arrow) in the Top Icons, and repeat with the
upper right corner of the rectangle, making sure it is on the line of Plane<2>.

• If either line is not over the green line representing the axis or plane, make sure you have selected
the Select Icon in the Sketch Icons, and click the line, and drag it over the green line and release.
(It should snap in place automatically).

• Click on the Zoom to Fit Icon in the top row of Icons, to see the whole sketch again.
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From the Sketch Icons > Click Dimension  (Add dimensions to the Rectangle)
• Click on the left line of the Rectangle, and drag away and click to set the Dimension Place,
• Click, Edit the dimension to be 2 mm (double-click in the value box, and enter 2.0, press Tab)
• Press Enter to accept the dimension (2 mm).
• 2mm is now displayed beside the left edge of the rectangle.

Create the Hollow Spout

From the Feature Icons, Click on Revolve Cut (4th Icon down)
• In the Revolve Cut popup, the Sketch to Revolve should be defaulted as Sketch<5>,
• If not - select Sketch<5> from the Design Explorer.
• Angle should be defaulted at 360 degrees, (If not, double-click the value and enter 360, Press Tab.)
• The Axis selection should be blank, click in the selection box, and Click the Z-Axis (Either in the

workspace or in the design explorer.)
• Label should say Revolution<5>. That is fine, or you may name it to your liking.
• Click OK.

Holding both Mouse buttons down (Left and right) drag until you can see inside the top of the
tube. You can see the now hollow stem at the top of the squeeze tube.

Now we will add the simple teeth, by editing the last sketch (Sketch<5>)
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Create the Simple Threads.

Edit the Revolve Sketch:
• Right-Click on Sketch<5> in the Design Explorer,
• Click on Edit in the drop down menu
• Click on Zoom to Fit in the top row Icons.

• Click on Line in the Sketch Icons,
• Start the line at the intersection of the extruded small circle and the plane<3>, Click and draw a

line 0.25 mm long along the edge of the extruded circle. (moving to the left from plane<3>)
Double-click to complete and exit the line.

• Click on Select in the Sketch Icons, Then Click the line just created,
• From the Main Menu, Click Sketch > Select Repeat > Linear,
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• In the Linear Repeat popup, Select Objects should show the selected Line<6>,
• Click in First Direction - Linear path selection box, and then click the Z-Axis (If the line does not

show to the left, click in the selection for Change direction.)

• Increase the Copies: from 2 to 4 (click the up arrow, or highlight the 2 and Enter 4, press Tab)
• Set Spacing at 0.8 mm (click the down arrow, or highlight the 1.0  and Enter 0.8, press Tab)

• Now in the Second Direction - Linear path: Click the selection box, and then click the right side
line on the Rectangle (Line<3>)

• Leave the Copies: at 2, and set the Spacing at 0.3 mm. (As Above) Click OK.
• This will create two parallel lines of 4 segments, each 0.25 mm long, separated by 0.3 mm.
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Now to re-locate the bottom line of segments to the mid-point in the gap of the segments in the
upper row.

While still having Select as the active Icon from the Sketch icons, click and drag a selection box
around all the segments in the lower line. The all should turn yellow.

• Click on the Zoom to Window Icon in the top row of Icons, and Select a Zoom Box for Line
• From the Main Menu, Click Sketch > Select Move.

• In the Move Figures Popup, click the From button, then click the right end of the lower line
(Highlighted Yellow) - at the edge of plane<3>.

• Now, in the Move Figures Popup, click the To button, place the cursor at the other end of the
same line (to the left) and move further 3 grid squares, and click.

• Leave Copy unchecked. Then Click Apply in the Move Figures Popup. Then Click Close.
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Now Show the Dimension the Move offset created between the two lines.
• Click Dimension in the Sketch Icons, and Click the End of the first line in the top row, and

Shift-Click the beginning of the first line in the bottom row.
• Carefully drag down, so the cursor is about mid-point between the end of the first line, and the

start of the second line, and below it, - click. Press Enter. Now - Click the figures and drag out to
the right for better visibility. (The dimension should be 0.15 mm)

• Do the same between the end of the first line in the second row and the beginning of the second
line in the first row. (The dimension should also be 0.15 mm.) (Both Dimensions are Equal)

Now connect the offset lines, with the line tool
• Click Line in the Sketch Icons, Click on the end of the first segment in the upper line, and double-

click the beginning of the first segment in the lower line.
• Click on the end of the first segment in the lower line, and the beginning of the second segment in

the upper line. Repeat to the end. (Manually)
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Now close these lines outside of the extruded circle by adding 3 lines to make a closed box with
them.
• With Line still selected, click on the end of the last segment, on the lower line, and drag up 0.5

mm. Then to the right until over the start of the first segment in the upper line (3.05 mm), and
then down to the start of the first segment, double-click to close the line.

• Now, click on the Select Icon in the top row of icons to exit the sketch mode, and to process the
new sketch features into the revolution, effectively creating the simple threads.

• You can now see the cut features highlighted in yellow.
• Click the Zoom to Fit Icon at the top. Click in the free area of the workspace to de-select the

(Yellow) new features.

Congratulations! You have now completed the modelling of the Loft-Tube-1
Now you can edit the loft tube's Color properties and save!
• Right Click in the Part Work Area Free Space, Select Color Properties from the Popup Menu.
• From the Color Properties Popup Window - Set the Reflectivity Slider to 10%,
• Leave Opacity at 100%,



Page 27 of 28

• Click on Color to select a new Color:
[i.e. Choose the 4th box down on the 3rd column over under Basic Colors - a Dark Green]

• Click OK to close the Color selection box and accept the new Color,
• Click OK to apply the Color to the model.
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Now, to save this file in it's own folder:
• From the main text menu, select File, Save As (Also Press Ctrl+Shift+S, the Shortcut Keys)

• From the Save As Popup, under File System: Explorer Directory name view - select Tutorials
folder.

• Click on New Folder - create one with the name Loft-Tube under Tutorials.
• Select this new folder named: Loft-Tube
Edit the name of the part - to Loft-Tube-1, and click - Save.

Congratulations!

You have completed the Loft-Tube-1 Tutorial!
(Complete Version)

Give me feedback on this tutorial!
Send email

If you found this and you don't yet have a copy of Alibre Design - Click this Link for a 30-Day Free Trial Copy!

mailto:alibre_rob@hotmail.com?subject=Loft-Tube-1_Complete
http://www.alibre.com/register/trial.aspx?source=CNSLT015

