
Alibre Design Tutorial - Simple Extrude
Step-Pyramid-1

Part Tutorial

Exercise 4: Step-Pyramid-1 [complete version]

In this Exercise, We will set System Parameters first.
Then, in sketch mode, outline the Step Pyramid with Rectangles and Straight Lines.
Then we will use the Extrude Feature to create the Step.
These two processes will be used 6 times to create the steps,
This will be followed by feature Mirroring to create the Whole Step Pyramid.

Launch Alibre Design.

From the Launch Window - select - Work Offline -



Or - From the Home window - select File, Work Offline.

Open a New Part workspace. From the Home window - click on the New Part icon.

Maximise the Part Workspace Window.



Set Design Properties.

Select File, Properties.

A)   Select the Tab Marked "General"
• In Description: insert the information: 'Step-Pyramid-1'.

• In Curve Smoothness, Select the Radio Button marked 'Automatic'.



B) Select the Tab Marked "Units"
• Check (check mark in box is showing) the Box Show Units for Dimensions.

• On Display Units - confirm Unit: Inches, Format: Decimals and Precision: 3.

• On Angle - Confirm Angle: Degrees and Precision: 3. Adjust if not.

• On Spinner Increment - for Length: enter .100 " and for Angle: enter 1.0000 degrees.

• Adjust to these parameters if not. Press 'Tab' to move after editing them.



C)   Select the Tab Marked "Physical"

• Change Accuracy: to High. Click on the Calculate Button. Notice the results.

D)   Select the Tab Marked "Apply Options"

• On Apply Changes to - Click the Radio Button beside The Current Document.

• Click Apply, then Click Close.



Set Part Options.

From Top Text Menu - Select - Tools > Options >

General Tab > Selected or checked off (check off = check mark in box) are:
Global - Show popup on errors,
Hints - All

Design
- Prompt for newer versions, - Snap to working plane, - Prompt to edit sketch,
- Prompt on detecting parameters with missing external link, - Reorient on extrude,
- Keep model in View, - Prompt when not sketching on face.



Show as Default - Planes, Annotations, and Sketches.
Number of stored previous/next views: 64

Grid Tab> Grid - Spacing: Make X: 0.100 " and Y: 0.100 ",
check off Display grid, and Snap to grid.

Color Scheme Tab> For Scheme: - confirm - Dark Background Scheme.

Click 'OK'.

This Completes the Options Setup.



Start the Profile Sketch.
From the Sketch Icons > Click Activate Sketch. (Notice the Grid is now displayed)

From the Top Text Menu - Select Sketch > Figures > Rectangle > Two Corners.

• Locate the cursor on the Origin, click, release and drag Up and Right until above the X-Axis,
and right of the Y-Axis, for a width of 2.000" and height of 2.000". click.

• Notice the lower right hand corner of the workspace - you will see two numbers.
If you want, you can use this as a guide to finish at 2.00, 2.00.



Create the First Step on the Pyramid from the Profile Sketch.

Select - from the Top Text Menu - Feature > Boss > Extrude.
(Alternative: Click Extrude Boss from the Feature Icons)

• Sketch - should already be selected as Sketch<1>, if not - click in the sketch selection area,
and on sketch<1> in design explorer, or in the part workspace.

• Type - is defaulted at To Depth,  - this can be left as is.

• Current Depth - is defaulted at 5.000 " - You may set this at any figure easily by picking up or
down selections beside the dimension display, or entering a correct number and pressing
'Tab'. For now, set it at 0.500 ". End images move out to reflect the new length. Leave
Reverse unchecked.

• Leave the Direction as Checked - Along Normal.

• For this - leave the Draft Angle at 0 degrees.
• Edit the Label to Pyramid-Step<1>.

• Click OK.



Create the Second Step Sketch on the Pyramid from the First Step Extrude.

Click on the top of the newly created Solid Surface.

• From The Sketching Icons, Click Project to Sketch.

• Prom the Popup, leave the Entities to project Selection at the default (face<5>).
Leave the Options - Create Sketch Figure, and Click - OK

• Select the top and right-side lines.
(Shift+Click for multiple selections. They turn Yellow when selected).



• From The Sketching Icons, Click Offset. Set the Distance for .250 ".
(Click in the Distance Selection between the '.' and the '500' - type a '2', and press 'Tab' key)

• There should be two lines defaulted in Figures to offset selection (Line<1>, Line<4>)

• Select Flip direction if lines are outside of selected (Yellow) lines.

• Confirm Distance = .250", and new lines (blue) are inside of the selected yellow lines. Click OK.

• Press the Delete Key - to remove the two selected lines.

• Select Trim Figure - from the Sketch Icons, or Trim from the Sketch Text Menu.

• Click once on each of the two .250" tails left outside of the new lines to Trim them away.



Create the Second Step on the Pyramid from the Profile Sketch.

Click Extrude Boss from the Feature Icons

• Sketch - should already be selected as Sketch<2>, if not - click in the sketch selection area, and
on sketch<2> in design explorer, or in the workspace.

• Type - is defaulted at To Depth,  - this can be left as is.
• Current Depth - is now defaulted at .500. End images reflect the length.
• Leave the Direction as Checked - Along Normal.
• For this - leave the Draft Angle at 0 degrees.
• Edit the Label - Pyramid-Step<2>.

• Click OK.

These two processes (Sketch, Extrude) will be used 6 times to create the steps, (Along
with Project to Sketch, Offset and Trim) which you can proceed with on your own, if you
like, or simply follow the steps below, as I walk you through them.



Create the Third Step Sketch on the Pyramid from the Second Step Extrude.

Click on the top of the newly created Solid Surface.
• From The Sketching Icons, Click Project to Sketch.

• Prom the Popup, leave the Entities to project Selection as is, (Face<3>) and
Options at the default - Create Sketch Figure, and Click - OK

• Select the top and right-side lines. From The Sketching Icons, Click Offset.
(Shift+Click for multiple selections. They turn Yellow when selected).

• There should be two lines defaulted in Figures to offset selection (Line<1>, Line<2>).
• Set the Distance for .250 ". (It may already be set at .250 ") Confirm new lines (blue) are inside

of the selected yellow lines, (Select Flip direction if lines are outside of selected lines.)
• Click OK.



• Press the Delete Key - to remove the two selected lines.

• Select Trim Figure from the Sketch Icons.
• Click once on each of the two .250" tails left outside of the new lines to Trim them away.

Create the Third Step on the Pyramid from the Profile Sketch.

Click Extrude Boss from the Feature Icons
• Sketch - should already be selected as Sketch<3>, if not - click in the sketch selection area, and

on sketch<3> in Design Explorer, or in the workspace.
• Type - is defaulted at To Depth,  - this can be left as is.
• Current Depth - is now defaulted at .500. End images reflect the length.
• Leave the Direction as Checked - Along Normal.
• For this - leave the Draft Angle at 0 degrees.
• Edit the Label - Pyramid-Step<3>.
Click OK.



Create the Fourth Step Sketch on the Pyramid from the Third Step Extrude.

Click on the top of the newly created Solid Surface.
• From The Sketching Icons, Click Project to Sketch.

• Prom the Popup, leave the Entities to project Selection as is, (Face<3>) and
Options at the default - Create Sketch Figure, and Click - OK

• Select the top and right-side lines.
(Shift+Click for multiple selections. They turn Yellow when selected).

• From The Sketching Icons, Click Offset.
• There should be two lines defaulted in Figures to offset selection (Line<1>, Line<2>).
• Set the Distance for .250 ". (It may already be set at .250 ") Confirm new lines (blue) are inside

of the selected yellow lines, (Select Flip direction if lines are outside of selected lines.)
• Confirm Distance at .250 ", and new lines (blue) are inside of the selected yellow lines,
• Click OK.



• Press the Delete Key - to remove the two selected lines.

• Select Trim Figure - either from the Sketch Icons, or Trim from the Sketch Menu.
• Click once on each of the two .250" tails left outside of the new lines to Trim them away.

Create the Fourth Step on the Pyramid from the Profile Sketch.

Click Extrude Boss from the Feature Icons
• Sketch - should already be selected as Sketch<4>, if not - click in the sketch selection area, and

on sketch<4> in design explorer, or in the workspace.
• Type - is defaulted at To Depth,  - this can be left as is.
• Current Depth - is now defaulted at .500. End images reflect the length.
• Leave the Direction as Checked - Along Normal.
• For this - leave the Draft Angle at 0 degrees.
• Edit the Label - Pyramid-Step<4>.
Click OK.



Create the Fifth Step Sketch on the Pyramid from the Fourth Step Extrude.

Click on the top of the newly created Solid Surface.
• From The Sketching Icons, Click Project to Sketch.
• Prom the Popup, leave the Entities to project Selection as is, (Face<3>) and

Options at the default - Create Sketch Figure, and Click - OK
• Select the top and right-side lines.

(Shift+Click for multiple selections. They turn Yellow when selected).
• There should be two lines defaulted in Figures to offset selection (Line<1>, Line<2>).
• Set the Distance for .250 ". (It may already be set at .250 ") Confirm new lines (blue) are inside

of the selected yellow lines, (Select Flip direction if lines are outside of selected lines.)
• Confirm Distance at .250 ", and new lines (blue) are inside of the selected yellow lines,
• Click OK.
• Press the Delete Key - to remove the two selected lines.
• Select Trim Figure - either from the Sketch Icons, or Trim from the Sketch Menu.
• Click once on each of the two .250" tails left outside of the new lines to Trim them away.



Create the Fifth Step on the Pyramid from the Profile Sketch.

Click Extrude Boss from the Feature Icons
• Sketch - should already be selected as Sketch<5>, if not - click in the sketch selection area, and

on sketch<5> in design explorer, or in the workspace.
• Type - is defaulted at To Depth,  - this can be left as is.
• Current Depth - is now defaulted at .500. End images reflect the length.
• Leave the Direction as Checked - Along Normal.
• For this - leave the Draft Angle at 0 degrees.
• Edit the Label - Pyramid-Step<5>.
Click OK.



Create the Sixth Step Sketch on the Pyramid from the Fifth Step Extrude.

Click on the top of the newly created Solid Surface.
• From The Sketching Icons, Click Project to Sketch.
• Prom the Popup, leave the Entities to project Selection as is, (Face<3>) and

Options at the default - Create Sketch Figure, and Click - OK
• Select the top and right-side lines.

(Shift+Click for multiple selections. They turn Yellow when selected).
• There should be two lines defaulted in Figures to offset selection (Line<1>, Line<2>).
• Set the Distance for .250 ". (It may already be set at .250 ") Confirm new lines (blue) are inside

of the selected yellow lines, (Select Flip direction if lines are outside of selected lines.)
• Click OK.
• Press the Delete Key - to remove the two selected lines.
• Select Trim Figure - either from the Sketch Icons, or Trim from the Sketch Menu.
• Click once on each of the two .250" tails left outside of the new lines to Trim them away.



Create the Sixth Step on the Pyramid from the Profile Sketch.

Click Extrude Boss from the Feature Icons
• Sketch - should already be selected as Sketch<6>, if not - click in the sketch selection area, and

on sketch<6> in design explorer, or in the workspace.
• Type - is defaulted at To Depth,  - this can be left as is.
• Current Depth - is defaulted at 5.000 " - You may set this at any figure easily by picking up or

down selections beside the dimension display, or entering a correct number and pressing 'Tab'.
For now, set it at 0.500 ". End images move out to reflect the new length.

• Leave the Direction as Checked - Along Normal.
• For this - leave the Draft Angle at 0 degrees.
• Edit the Label - Pyramid-Step<6>.
• Click OK.

Create the completed Pyramid in the next steps.



The Pyramid will be completed by Feature Mirroring (2 X) to create the Whole
Step- Pyramid-1.

From the Feature Menu, Select Mirror (1st time)

• In the Features Mirror Popup Window - under Features to mirror: shift+click to select all 6
features, from Pyramid-Step<1>, to Pyramid-Step<6> in the Design Explorer.

• Leave Mirror Geometry selected.



• Under Mirror plane: select on of the flat faces of the collective features [i.e.: Face 17], and you
will see the lines appear indicating where the features will be mirrored.

• Rename Label: to 1/2 Pyramid

• Click OK.

You now have one - half of the full step pyramid completed.



You can now complete the full step pyramid.

Again, From the Feature Menu, Select Mirror (2nd time)
• In the Features Mirror Popup Window - under Features to mirror: shift+click to select all 6

features, from Pyramid-Step<1>, to Pyramid-Step<6> Plus 1/2 Pyramid in the Design Explorer

• Under Mirror plane: select on of the flat faces of the collective features [i.e.: Face 16], and you
will see the lines appear indicating where the features will be mirrored.



• Rename the Label: from Mirror<8> to Pyramid Full
• Click OK.

Congratulations!
You have now completed the modelling of the Step Pyramid.

Now, to save this file in it's own folder:
• From the main text menu, select File, Save As

• From the Explorer directory view - select Tutorials folder.
(Or - Create New Folder - name it Tutorials)

• Click on New Folder - create one with the name step-pyramid under Tutorials.



• Select this new folder named: step-pyramid
• Edit the name of the part - to Step-Pyramid-1, and click - Save.

If you want - you can edit the pyramids Color properties and re-save!

• Click Edit, Color Properties,
• From the Color Properties Popup Window - Set the Reflectivity Slider to 10%,
• Leave Opacity at 100%,

• Click on Color to select a new Color:
[i.e. Choose the 4th box down on the left under Basic Colors - a Reddish Brown]

• Click OK to close the Color selection box and accept the new Color,



• Click OK to apply the Color to the model.

Now, to Update save this file:
• From the Top Standard Icons - select Save. (The Floppy disk Icon.)
• On the Popup - under Version Properties, Comment, enter - Colored.
• Select Save.

Congratulations!
You have completed the Step-Pyramid-1 Tutorial!

(Complete Version)
If you found this and you don't yet have a copy of Alibre Design - Click this Link for a 30-Day Free Trial Copy!

http://www.alibre.com/register/trial.aspx?source=CNSLT015

