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Alibre Design Tutorial: Sweep, Extrude Boss, & Fillet
Sweep_Toilet-Seat-Lid-1

Part Tutorial

Exercise 7: Sweep_Toilet-Seat-1 [text version]

In this Exercise, We will set System Parameters first, then part options,
Then setting up the save, at the beginning - so as to save easily as we perform each step.
Then, in sketch mode, we will set the first sketch of the seat for the Extrude Feature.
Then we will use the Sweep Feature to create the Primary Smooth edge.
Then we will use fillet to smooth the bottom edge so it is not sharp.
Setting the Color Properties will follow this, and re-saving the file.

Launch Alibre Design.
From the Home window - select File, Work Offline. (You may switch to work online later)
Open a New Part workspace. From the Home window - click on the New Part icon.
Maximise the Part Workspace Window.

Set Design Properties.

Select File, Properties.
A)   Select the Tab Marked "General"

• In Description: insert the information: 'Sweep_Tolet-Seat-1'.
• In Curve Smoothness, Select the Radio Button marked 'Manual', and set the 'Minimal Circular

Facets:' at 48.
B) Select the Tab Marked "Units"

• Check (check mark in box is showing) the Box Show Units for Dimensions.
• On Display Units - confirm Unit: Inches, and Precision: 2.
• On Angle - Confirm Angle: Degrees and Precision: 3. Adjust if not.
• On Spinner Increment - for Length: enter 0.10" and for Angle: enter 1 degrees.

 Adjust to these parameters if not. Press 'Tab' to move after editing them.
C)   Select the Tab Marked "Apply Options"

• On Apply Changes to - Click the Radio Button beside The Current Document.
• Click Apply, then Click Close.
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Set Part Options.
From Top Text Menu - Select - Tools > Options >
General Tab > Selected or checked off (check off = check mark in box) are:
Global - Show popup on errors,
Hints - All
Design
- Prompt for newer versions, - Snap to working plane, - Prompt to edit sketch,
- Prompt on detecting parameters with missing external link, - Reorient on extrude,
- Keep model in View, - Prompt when not sketching on face.
Show as Default - Planes, Annotations, and Sketches.
Number of stored previous/next views: 64
Grid Tab> Spacing: Make X: .1 " and Y: .1 ", check off Display grid, and Snap to grid.
Color Scheme Tab> For Scheme: - confirm - Dark Background Scheme. Click 'OK'.
(You may come back to this at any time later - and edit - or change - any element.)

Set-up Save.
Now, to save this in it's own folder, making it easy to simply save as we proceed:
• From the main text menu, select File, Save As. (Also Press Ctrl+Shift+S, the Shortcut Keys)
• From the Explorer directory view - select Tutorials folder.
• Click on New Folder - create one with the name Sweep_Toilet-Seat under Tutorials.
• Select this new folder named: Sweep_Tolet-Seat
• Edit the name of the part - to: Sweep_Toilet-Seat-1, and click - Save.

Start the First Sketch (for the extruded shape).
From the Sketch Icons > Click Activate Sketch. (The first Icon) (The XY-Plane should be selected.)

From the Sketch Icons > Click Line (The 5th Icon down)
• Click the Origin, and drag a line out to the Right along the 'X' Axis 3.5 " - Double Click to end the line.

From the Sketch Icons > Click Line Options (Below Line Icon) -> Select Reference Line
• Click the Origin, and drag a vertical Reference Line up the 'Y' Axis 6.0 " - click,
• Continue dragging another line up the 'Y' Axis 7.0 " - Double Click to end the line.
• From the point up the 'Y' axis - click the point, or node between the two lines, and drag a line out to the

right 5.5 " - Double Click to end the line.

From the Sketch Icons > Click Dimension (4th Icon down)
• Click the Bottom Line - along the 'X' Axis, and drag the dimension up above it - Click, Confirm the

Length is 3.5 " or edit to be 3.5" and press Enter.
• Above that, Click the Horizontal Reference line, and drag the dimension down below it - Click,

Confirm the Length is 5.5 " or edit to be 5.5" and press Enter.
• Click the first Vertical Reference line and drag the dimension off to the left a bit, Click, Confirm the

Length is 6.0 " or edit to be 6.0" and press Enter.
• Click the second Vertical Reference line and drag the dimension off to the left a bit, Click, Confirm the

Length is 7.0 " or edit to be 7.0" and press Enter.
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From the Sketch Menu > Select Figures -> Elliptical Arc
• Click the Center Point between the 6.0 " and 7.0 " Reference lines where the Horizontal Reference line

meets them,
• For the First Radius - drag up to the top of the 7.0 " Line - Click,
• For the Second Radius - drag to the right to the end of the 5.5 " Reference Line - Click,
• To Select the Start Point on Edge - click again on the End of the 5.5 " Reference Line, and drag the

mouse icon up the curve to the top of the 7.0 " line - Clicking on it to complete the arc.

From the Sketch Icons > Click Arc Options (Below Arc) -> Select Circular Arc: Start, End, Radius
• Click the bottom end of the newly added Circular Arc, then click the end at the right of the 3.5 " Long

Line along the 'X' Axis
•  Drag the cursor out to the right to create an arc, which basically follows the path of the Elliptical Arc

above it, Click to complete.

From the Sketch Icons > Click Constraint Options (Below Constraints) -> Select Tangent Constraint
• Click the First Figure for the Tangent Constraint - click the Elliptical Arc,
• Click the Second Figure for the Tangent Constraint - Click the Circular Arc we just created above.

From the Sketch Icons > Click 2D Fillet (5th Icon from the bottom)
• Click the newly added Circular Arc, then click the end at the 3.5 " Long Line along the 'X' Axis,
• Set the Radius to 1.0 ", (Click the up arrow to change from the default .50 "),
• Click Apply, then Click Close.

From the Sketch Icons > Click Dimension (4th Icon down)
• Click the New 2D Fillet, and drag the cursor to a spot up and inside the arcs to place the Radius

Dimension, Click, and press Enter.

From the Sketch Icons > Click Select (The '+' Symbol at the Second from the Top)
• Click and drag a selection box around the whole sketch created so far,
• Shift-Click the two vertical Reference lines, one after the other, to De-Select them, then -

From the Sketch Icons > Click Mirror (2nd Icon from the bottom)
• The Mirror Figure popup selector already has items listed in Figures to Mirror, these are the ones that

we just highlighted,
• Not yet filled out is the Mirror axis selection, so - click in that white space,
• Then Click on one of the Vertical Reference Lines,
• Then Click OK to complete the mirror.

From the Sketch Menu > Select Analyse
• The Analyse Sketch popup has a number of selections to check - marked with boxes beside them - for

this exercise - they all should be checked,
• Click the Analyse Button - Ideally you should see a message below this button that is now displayed

stating "No Potential problems detected in the sketch for the current check levels…" (That is why you
want them all checked in the boxes!) (Email me if you get stuck on this one)

• A Common issue after a mirror - is Disjoint Ends. Click on this listed item, then click the Heal Button
to correct it. Then you should get 'No Potential Problems detected….'.
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From the Features Icons Select Extrude Boss
• The extrude Boss popup shows Sketch as Sketch<1>, Direction Along Normal should be Checked,
• Type: should be To Depth, and Depth should be set to 1.0 ", edit it and then click Tab to update,
• Draft Angle should be 0, and label should be Extrusion<1>, (This can be easily edited later)
• Once all these things are set like this - Click OK to Complete the Extrusion and accept the parameters.
• Click on the Save Icon (Floppy Disk) or select File, Save (Or Ctrl+S) to update our save of the file.

Start the Second Sketch (for the Sweep shape).

In the Part Workspace, Rotate the Extruded Feature to present the top face easily, Then click the
Top Surface (The newly created face - away from the 'XY' Plane) to Select it, (It will turn Red - then
Yellow When you move your mouse away)

 From the Sketch Icons > Click Project to Sketch (1st Icon at the bottom) _
• The Project to Sketch popup selector already has items listed in Entities to project, these are the ones

that we just highlighted, (Face<#>)
• Click OK to accept the default Option - Create Sketch figure.

In the Design Explorer, Select the 'YZ plane' - then From the Sketch Icons > Click Activate Sketch.
• In the View Orientations Icons, Select Orient to right, then use Zoom to Window to select a close-up of

the edge on the Z-Axis.

From the Sketch Icons > Click Line (The 5th Icon down)
• Click the Origin, and drag a line out to the Left along the 'Z' Axis 1.0 " - Double Click to end the line.
• Click the Origin, and drag a line out away from the extruded feature 90 degrees to the first - down 1.2 "

- Double Click to end the line.

From the Sketch Menu, Select Figures, -> Elliptical Arc
• Click the Origin to set the center point of the Elliptical Arc, at the start point of the two lines created,
• Click the End Point of the 1.2 " line down from the feature for the major axis of the elliptical arc,
• Click the End Point of the 1.0 " Line away from the Origin for the minor axis of the elliptical arc,
• Before Moving Away from the end of the 1.0 " Line, click again to pick the point for the start point of

the elliptical arc,
• Follow the path of the preview ellipse to the end of the 1.2 " Line away from the extruded feature -

click to complete the elliptical arc.

From the Sketch Menu > Select Analyse
• The Analyse Sketch popup has a number of selections to check - marked with boxes beside them - for

this exercise - they all should be checked,
• Click the Analyse Button - Ideally you should see a message below this button that is now displayed

stating "No Potential problems detected in the sketch for the current check levels…" (That is why you
want them all checked in the boxes!) (Email me if you get stuck on this one)

• A Common issue after a mirror - is Disjoint Ends. Click on this listed item, then click the Heal Button
to correct it. Then you should get 'No Potential Problems detected….'.
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From the Sketch Icons, Select Activate Sketch
(We are in the Sketch Mode - this is a toggle - to Exit Sketch Mode)

From the Feature Icons Click the Sweep Boss Icon, or From the Feature Menu - Select Boss ->
Sweep.
• Click in the white area for Sketch to Sweep, then Click Sketch<3> in the Design Explorer
• Click in the white are for Path Object, then Click Sketch<2> in the Design Explorer,
• Confirm - Sweep Type is set to Entire Path, Draft Angle is set to 0,
• Label: is currently Sweep<2> - which is fine for now, but may be edited easily later,
• Click OK when all these items are set up, to complete the Sweep.
• Click on the Save Icon (Floppy Disk) or select File, Save (Or Ctrl+S) to update our save of the file.

Almost done! Just add a 3D Fillet on the Sharp edge, some Color and that's it!

In the Part Workspace, Rotate the Extruded and Swept Feature to present the Bottom face easily,
Then Click the Bottom Surface (The face - along the 'XY' Plane) to Select it, (It will turn Red - then
Yellow When you move your mouse away)

From the Feature Icons Click the Fillet Icon - or From the Feature Menu - Select Fillet.
• The Fillet Edges popup selector shows Face<8> pre-selected in Entities to fillet,
• Set the Radius: value to .10 " and click Tab to update the preview,
• The Label: is currently Fillet<3>, and while you can give this any name you want, this is fine for now.
• Leave Tangent Propagate Selected, and also leave Fillet Type to Constant Radius,
• Click OK to complete the Fillet.

From the Edit Menu - Select Color Properties.
• Leave Opacity at 100%, Set Reflectivity to 10% by Clicking to the right of the slider once,
• Select the Color button - and from the Basic Colors - click the Far right side - Top row - Mauve Color,
• Click OK to accept the Color and close the Color selector,
• Then Click OK to Close the Color Properties popup and accept the settings of Color, Reflectivity, and

Opacity.
• Click on the Save Icon (Floppy Disk) or select File, Save (Or Ctrl+S) to update our save of the file.

Congratulations!

You have completed the Sweep_Toilet-Seat-Lid-1 Tutorial!
(Text Version)

Give me feedback on this tutorial!
Send email

If you found this and you don't yet have a copy of Alibre Design - Click this Link for a 30-Day Free Trial Copy!

mailto:alibre_rob@hotmail.com?subject=Sweep_Toilet-Seat-Lid-1_Text-Only
http://www.alibre.com/register/trial.aspx?source=CNSLT015

